Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Support Us

Top Posters

Installing Linux Distro's That Aren't X86_64

DanDDDanDD Registered
edited September 2015 in General
I never seem to have any luck installing distros that are not X86_64. Distros such as Makulu, Puppy, 4MLinux, etc, I can't get them to work.  Is there a setting for Virtual Box that I need to check, or a setting in the computer itself.  It seems that only X86_64 distros can be installed on my Mac computer.  Any help will be appreciated, thanks.

Comments

  • KDGKDG Registered
    i can install 32bit and 64bit on virtualbox on my mac..

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • irishluck83irishluck83 Administrator
    @DanDD what type of errors or behavior is it doing when you try to install a 32-bit system?
  • DanDDDanDD Registered
    @irishluck83, its not 32 bit systems, its distros with different architectures that I'm having trouble with.  Distros that are i386, i686, i486, etc.
  • KDGKDG Registered
    are i366 and i686 32 bits?

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • DanDDDanDD Registered
    @KDG, they can be 32 or 64 bit.
  • setkehsetkeh Administrator
    i386, i686, i486, Are 32 bit architectures they are perfectly capable of running on a X86_64 machine although they will have limited hardware usage ability such as not using more than 4 GB of ram and hard drives up to a certain size. and there is no reason why they wont work running inside virtualbox on a 64bit host OS such as OSX, Windows, Linux, BSD you need to provide more error logs and screenshots if possible we cant trouble shoot an issue that has no more context than "its not working"



    Wisdom:

    One does not Simply Deploy into Production.

  • DanDDDanDD Registered
    @setkeh, I didn't say "its not working",sure, I can get them to work in "Live Mode", but I can't seem to get them to accept my user name and password.  Every time I think they are installed and restart them, they just keep going to "Live mode", and I have to keep reinstalling them, and it still doesn't take.
  • KDGKDG Registered
    eject CD/DVD/ISO from Virtualbox !!

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • setkehsetkeh Administrator
    @DanDD Thats because virtualbox by default boots virtual machines from CD/DVD after you complete the install you can either 

    Change the boot priority in the virtual machines settings (recommended)
    or
    Just simply eject the live media from the virtual machine on reboot to stop it rebooting to live enviroment.



    Wisdom:

    One does not Simply Deploy into Production.

  • KDGKDG Registered
    edited October 2015
    @setkeh yea my point :)

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • DanDDDanDD Registered
    @setkeh, and @KDG, most of the time I get a prompt to eject the live media from rebooting, but sometimes I don't.  I'm not sure what setting in Virtual Box to use to set the boot priority, and what to change it to.
  • KDGKDG Registered
    remove .iso from boot..

    same place then u add .iso ..

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • KDGKDG Registered

    Screen shot 2015-10-05 at 01.12.44

    IRC nick Name:             KDG
    Mumble nick Name:      KDG

    My-YouTubeChanne
    update as of 2017
    My-GitHub
  • setkehsetkeh Administrator
    You can change to Boot Priority (order) in the System menu in settings. Use the Arrows to the right to move hard disk to the top of the list or uncheck the optical disk option all together to prevent it from booting from the iso.


    image



    Wisdom:

    One does not Simply Deploy into Production.

  • DanDDDanDD Registered
    Thanks KDG and setkeh, very helpful screen shots.
Sign In or Register to comment.