Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Support Us

Top Posters

[Solved] How to write files to a HFS+ Formatted Hard Drive?

I have a 320GB Blue Iomega Hard Drive that I formatted in 2008/2009 from NTFS to HFS+ for video editing with Final Cut Pro with my Mac. I have no problem reading and copying from it, but I can not write files/folders to the external drive. I took a look in the permissions tab of the properties window of the drive, and it says "Your not the owner of the drive, so you may not change any settings here" or something like that. This happens on both Firewire and USB connections. Is there anyway to fix this?
Theodore Thorpe,
Member of the Cup Of Linux, Linux Distro Community & Linux Lite Forums.
OS: Manjaro XFCE 64-Bit & Linux Lite 64-Bit

Comments

  • plustwoplustwo Registered
    Teddy5090 wrote:
    I have a 320GB Blue Iomega Hard Drive that I formatted in 2008/2009 from NTFS to HFS+ for video editing with Final Cut Pro with my Mac. I have no problem reading and copying from it, but I can not write files/folders to the external drive. I took a look in the permissions tab of the properties window of the drive, and it says "Your not the owner of the drive, so you may not change any settings here" or something like that. This happens on both Firewire and USB connections. Is there anyway to fix this?

    You might need to install "hfsprogs" (sudo apt-get install hfsprogs). And then issue "sudo mount -t hfsplus -o remount,force,rw /dev/sdx# /mount/point".

    Otherwise you will have to disable journaling on the Mac machine for that drive(not recommended).
    You might also check the following links for more info; http://lifehacker.com/5702815/the-complete-guide-to-sharing-your-data-across-multiple-operating-systems
    and http://packages.debian.org/sid/hfsprogs

    tnx
  • That worked! Thanks PlusTwo!
    Theodore Thorpe,
    Member of the Cup Of Linux, Linux Distro Community & Linux Lite Forums.
    OS: Manjaro XFCE 64-Bit & Linux Lite 64-Bit
  • Hi, what procedure worked for you?

    The one plustwo suggested (You might need to install "hfsprogs" (sudo apt-get install hfsprogs). And then issue "sudo mount -t hfsplus -o remount,force,rw /dev/sdx# /mount/point").

    Or something you found in website to which he sent you the link?

    Thanks.
Sign In or Register to comment.