Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Support Us

Top Posters

How to fix "'user' is not in sudoers" in CentOS

I just ran into this issue, and I'm sure I'm not going to be the last person to do so. This is my first tutorial, so I'm hoping I did everything the right way. It's a simple fix, so this is definitely one of the shortest how-to's ever.

First thing (for the way I do it) is to make sure you have nano. If not, log onto the root account and download nano before anything else:
sudo yum install nano

With that, it's time to edit the sudoers file to add yourself to it:
EDITOR=nano visudo

Now, navigate to the area where it says:
## Next comes the main part: which users can run what software on
## which machines (the sudoers file can be shared between multiple
## systems).
## Syntax:
##
##	user    MACHINE=COMMANDS
##
## The COMMANDS section may have other options added to it.
##
## Allow root to run any commands anywhere
root    ALL=(ALL)	ALL

## Allows members of the 'sys' group to run networking, software,
## service management apps and more.

And under where it says
root   ALL=(ALL)     ALL
place the name of the user that you want to give sudo rights to so that it looks something like this:
## Next comes the main part: which users can run what software on
## which machines (the sudoers file can be shared between multiple
## systems).
## Syntax:
##
##	user    MACHINE=COMMANDS
##
## The COMMANDS section may have other options added to it.
##
## Allow root to run any commands anywhere
root    ALL=(ALL)	ALL
Chris   ALL=(ALL)	ALL
## Allows members of the 'sys' group to run networking, software,
## service management apps and more.

ctrl-X to exit, y to agree to save it and enter to save the file with the name as it is and you're done!

Comments

  • Lyxer01Lyxer01 Registered
    Very Nice Obsidian!

    This also applies for pretty much any other distro as well that has sudo installed. Making it pretty convenient switching over from different machines.

    Thanks for sharing this, im sure somebody is gonna get some use out of this :)

    Warm regards, Lyxer01
  • You can also set your default editor in your defaults line

    Defaults editor=/usr/bin/nano

    then visudo will use nano everytime:)
  • Thanks for the comments fellas :D
  • setkehsetkeh Administrator
    just a caution

    visudo actually checks the sudoers file if you go changing your editors around and make a mistake in your sudoers files if could break sudo and the root user thats just a FYI

    i use nano all the time :P i dont even change visudo perams :P



    Wisdom:

    One does not Simply Deploy into Production.

  • jagginessjagginess Registered
    I transferred a post for EDITOR= to a new thread
Sign In or Register to comment.